
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20190926042601
template: 
currentrequest: /apps/pbcs.dll/article?avis=CA&date=20190926&category=NEWS&lopenr=190929883&Ref=AR
currentrequestunmodified: /news/20190926/county-employees-changes-to-healthcare-would-be-financial-burden
@templatetype: /apps/pbcs.dll/article?avis=CA&date=20190926&category=NEWS&lopenr=190929883&Ref=AR
@pagetype: article
app version: 2.0.376
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Mount Shasta Herald - Mount Shasta, CA" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> County employees: changes to healthcare would be financial burden - News - Mount Shasta Herald - Mount Shasta, CA - Mount Shasta, CA</title>
<!-- Meta Tags - Global Article6 guid: 64DD16FC-CE1E-42B9-8B6E-98C7C077CC4A-->
<meta name="description" content="Much like the large group of local Tradecraft Bargaining Unit workers who had flooded the chambers the previous week to oppose changes to their benefits, the OESC group was also asking the county not to put a cap on their health insurance.
" />
<meta property="bt:pubDate" content="20190926T00:01:00Z">
<meta property="bt:modDate" content="20190925T08:18:00Z">
<meta property="bt:keywords" content="Benefits,Caps,County,Insurance,Siskiyou,Supervisors">
<meta property="bt:author" content="Danielle Jester">
<meta name="twitter:title" content="County employees: changes to healthcare would be financial burden">
<meta name="twitter:description" content="Much like the large group of local Tradecraft Bargaining Unit workers who had flooded the chambers the previous week to oppose changes to their benefits, the OESC group was also asking the county not to put a cap on their health insurance.
">
<meta property="og:title" content="County employees: changes to healthcare would be financial burden"/>
<meta property="og:description" content="Much like the large group of local Tradecraft Bargaining Unit workers who had flooded the chambers the previous week to oppose changes to their benefits," />
<meta name="author" content="Danielle Jester">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.mtshastanews.com/storyimage/CA/20190926/NEWS/190929883/AR/0/AR-190929883.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.mtshastanews.com/storyimage/CA/20190926/NEWS/190929883/AR/0/AR-190929883.jpg">
	<meta property="og:image:width" content="1024">
	<meta property="og:image:height" content="681">
	<meta property="vf:unique_id" content="siteCA-pub245-64DD16FC-CE1E-42B9-8B6E-98C7C077CC4A">
	<link rel="canonical" href="https://www.mtshastanews.com/news/20190926/county-employees-changes-to-healthcare-would-be-financial-burden"/>
<link rel="amphtml" href="https://www.mtshastanews.com/news/20190926/county-employees-changes-to-healthcare-would-be-financial-burden?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.mtshastanews.com/news/20190926/county-employees-changes-to-healthcare-would-be-financial-burden"
	},
    "headline": "County employees: changes to healthcare would be financial burden",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.mtshastanews.com/storyimage/CA/20190926/NEWS/190929883/AR/0/AR-190929883.jpg",
       	"height": 681,
       	"width": 1024
    },
    "url": "https://www.mtshastanews.com/article/20190926/NEWS/190929883",
    "thumbnailUrl": "https://www.mtshastanews.com/apps/pbcsi.dll/bilde?Site=CA&Date=20190926&Category=NEWS&ArtNo=190929883&Ref=AR",
    "dateCreated": "20190926T08:01:00Z",
    "datePublished": "20190926T08:01:00Z",
    "dateModified": "20190925T16:18:00Z",
    "author": [{"@type":"Person","name":"Danielle Jester"}],
    "creator": "Danielle Jester",
    "publisher": {
       "@type": "Organization",
       "name": "Mount Shasta Herald - Mount Shasta, CA",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.mtshastanews.com/Global/images/head/nameplate/mountshastaherald_logo.png"
       }
    },
    "articleSection": "News",
    "keywords": ["Benefits", "Caps", "County", "Insurance", "Siskiyou", "Supervisors"],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Mount Shasta Herald",
    "productID": "mtshastanews.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="147251848695030"/>
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>
<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script>
docReady(function()
{ ims.startServices(); }
);
</script>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.376/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
    	.ad-300x250{
	    	min-height: 250px;
    	}
    	#interstitial-nondistroscale{
	    	clear:both;
    	}
    	.ad-300x150{
	    	width: 300px;
	    	max-height: 150px;
    	}
    	.articleInjectAd{
	    	display: none;
    	}
    	.native-injected{
	    	height: 0px;
    	}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	/* Buzz widget */
    	#gh-slider-buzz > div > div > figure > a > div.image.unveil-loaded{
			min-height: 112px;
			box-shadow: 0px 0px 5px 0px rgba(50, 50, 50, 0.75);
			border-radius: 2px;
    	}
    	#gh-slider-buzz{
    		font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
    	}
    	#gh-slider-buzz h3 > span{
    		font-weight: bold;
			font-size: 14.4px;
			color:rgb(68, 68, 68);
			text-decoration-color:rgb(68, 68, 68);
			line-height: 16px;
    	}
    	#gh-slider-buzz h3 > span:hover{
			text-decoration: underline;
    	}
    	#gh-slider-buzz .dateline{
			font-size: 10px;
			color:rgb(153, 153, 153);
			text-decoration-color:rgb(153, 153, 153);
    	}
    	#gh-slider-buzz .gh-slider-caption h3{
	    	max-height: 500px;
    	}
    	#gh-slider-buzz div.nophoto > a > h3{
	    	margin-bottom: 5px;
    	}
    	#gh-slider-buzz div.nophoto{
	    	padding:0px;
    	}
    	#gh-slider-buzz span.summary{
	    	font-size: 11px;
		    max-height: 140px;
		    display: block;
		    line-height: 14px;
		    overflow: hidden;
    	}
    	#gh-slider-buzz .slick-slider,#buzz-widget-mobile .section-ribbon,#buzz-widget .section-ribbon{
	    	margin-bottom: 0px;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.mtshastanews.com/news" target="_top">News</a></li><li><a href="https://www.mtshastanews.com/sports" target="_top">Sports</a></li><li><a href="https://www.mtshastanews.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.mtshastanews.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.mtshastanews.com/obituaries" target="_top">Obituaries</a></li><li><a href="http://mountshasta.ca.newsmemory.com" target="_blank">E-Edition</a></li><li><a href="https://www.mtshastanews.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.mtshastanews.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.mtshastanews.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Casis" target="_blank">Classifieds</a></li><li><a href="https://www.mtshastanews.com/section/blogs" target="_top">Blogs</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.mtshastanews.com/subscribe?g2i_source=mtshastanews.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=MSHM&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.mtshastanews.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.mtshastanews.com">
							<img class="mainheadnameplate" src="https://www.mtshastanews.com/Global/images/head/nameplate/mountshastaherald_logo.png"  alt="Mount Shasta Herald - Mount Shasta, CA" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.mtshastanews.com/subscribe?g2i_source=mtshastanews.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.mtshastanews.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.mtshastanews.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20190925081828">
	<div class="inner">
		<h1 class="headline">County employees: changes to healthcare would be financial burden</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.mtshastanews.com/storyimage/CA/20190926/NEWS/190929883/AR/0/AR-190929883.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">A crowd of county employees gathered at the Sept. 17 meeting of the Siskiyou County Board of Supervisors to explain what a proposed cap to their health insurance would mean to them.</div>
                <div class="credit">Danielle Jester</div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					Danielle Jester
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Thursday</h3>
							<span class="article-meta-date">Sep&nbsp;26,&nbsp;2019&nbsp;at&nbsp;12:01&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary">Much like the large group of local Tradecraft Bargaining Unit workers who had flooded the chambers the previous week to oppose changes to their benefits, the OESC group was also asking the county not to put a cap on their health insurance.</p>
					<p><p>Members of the Organized Employees of Siskiyou County, a public employee association, filled the Siskiyou County Board of Supervisors&rsquo; chambers during the board&rsquo;s Sept. 17 meeting. Much like the large group of local Tradecraft Bargaining Unit workers who had flooded the chambers the previous week to oppose changes to their benefits, the OESC group was also asking the county not to put a cap on their health insurance.</p>
<p>As the matter was brought forward during public comment, the board did not discuss the topic or take any action.</p>
<p>Sarah Johnson, who works as an alcohol and drug counselor for Siskiyou County Behavioral Health, said that as a single mother of two young children she can&rsquo;t cover all of her expenses on her county salary. &ldquo;I worked really hard to get my college degree and certification to work in this field and get off welfare,&rdquo; she told the supervisors, adding, &ldquo;While I&rsquo;m no longer receiving cash aid, my children and I are still receiving public assistance.&rdquo;</p>
<p>Johnson said that if the county decides to put a cap on her health insurance, she will not be able to afford to make ends meet or to provide for her children&rsquo;s basic needs. If she had to pay for health insurance, Johnson said she would no longer be able to work for the county.</p>
<p>&ldquo;I&rsquo;m very proud to say that I work for the County of Siskiyou and I&rsquo;d like to see the county tell their employees they are proud of the work we do by not putting a cap on our health insurance,&rdquo; she concluded.</p>
<p>Jenna Faris, who has been a County of Siskiyou employee for five years, also spoke, noting that she was representing her coworkers in adult and children&rsquo;s services.</p>
<p>&ldquo;I sit before you to express opposition to increasing healthcare premiums paid by employees,&rdquo; she told the supervisors.</p>
<p>Employees in the adult and children&rsquo;s services department assist the homeless, the addicted, the mentally ill, the children and the elderly in the local community, Faris said. &ldquo;We freely enter the homes of dangerous felons with no more than a clipboard and a cell phone. We are exposed to diseases such as MRSA, shingles, and hepatitis on a daily basis. We serve this population knowing that we face these hazards. We do it because we love the idea of improving our community,&rdquo; she explained.</p>
<p>&ldquo;In child welfare, we aim to help people develop their abilities to use their own resources to resolve problems and to positively contribute to our community,&rdquo; Faris continued. &ldquo;We are advocates for the most at-risk children in the county. In adult services, we inform and assist those who may have been victims of scams, abuse, financial exploitation and neglect. We advocate for the elderly when they are unable to advocate for themselves and we help them to regain their dignity. As social workers, we are extremely passionate about the assistance we provide to the county&rsquo;s most vulnerable population.&rdquo;</p>
<p>Faris then told the supervisors that an increase in health insurance costs for OESC members would cause financial hardship for the employees and their families and would force the workers to seek employment elsewhere.</p>
<p>She noted that families with young children are already overburdened with out of pocket expenses which their current health plan does not cover. Even families without children are finding it difficult to make ends meet with medical costs that exceed what the health plan covers, she said. And some employees forgo medical treatment altogether, Faris said, because they fear exorbitant out of pocket expenses.</p>
<p>Joy Hall, who has worked for Siskiyou County for nearly 13 years said if a cap were placed on the employees&rsquo; health insurance, she would need to set aside nearly $430 from each of her paychecks to cover the insurance expenses.</p>
<p>OESC is being asked to agree to a two percent raise, which Hall said would equate to only about $24 more take home pay each pay period for an employee making $20 an hour.</p>
<p>She told the supervisors, &ldquo;OESC has conceded a lot in the past. A few years ago we were told the county was broke and we would either have to lay off employees or take a pay cut. We opted for the pay cut so as not to lose workforce that we desperately need in the county ... We have given up a lot in the past and are being asked to give up more, even though we haven&rsquo;t recovered from last time.&rdquo;</p>
<p>Hall was not the first employee to address the difficulty of recruiting and retaining county employees due to the low rate of pay compared to other counties.</p>
<p>&ldquo;We lose great people who want to stay employed with the county but leave because they can&rsquo;t afford to stay,&rdquo; she said, adding that her own department has five vacancies. &ldquo;Clinician social workers who should have a case load of less than 15 have over 30,&rdquo; Hall said. &ldquo;Being short staffed or having a huge workload weighs on your employees immensely and causes absences due to stress and illness, not to mention the cost to the county to train new staff every time for the turnovers,&rdquo; she stated.</p>
<p>Matt Rokes was the last member of the public to speak about the issue at the Sept. 17 meeting. Rokes is a labor representative with the law firm Goyette and Associates, which represents OESC. In addition to that job, Rokes said that he is a second generation retired Siskiyou County employee and spent 37 years either as a full time paid peace officer or as a volunteer. &ldquo;And in fact I still volunteer for the county ag department doing large animal rescue and fire evacuations,&rdquo; he said.</p>
<p>Rokes said that Goyette had negotiated or attempted to negotiate with the county and had come to an impasse.</p>
<p>He stated, &ldquo;We&rsquo;ve reached out to the board. We were hoping to meet with you over a cup of coffee and not fill your board room and do it in this manner but we&rsquo;ve been left with no choice. Please come back to table, negotiate in good faith with these employees. They are dedicated, they are overworked, underpaid and desperate for a deal so they can get back to work.</p>
<p>&ldquo;This is a quality of life issue, not just for the employees but for the entire county. The jobs they do are critical for the quality of life of a lot of people in this county. They can&rsquo;t recruit, they can&rsquo;t retain and they can&rsquo;t pay their bills. Please reconsider, get with your staff, come up with a decent proposal and meet with us straight up,&rdquo; he pleaded with the board.</p>
<p>District 2 Supervisor Ed Valenzuela said that he had also worked as a union representative years ago and that regular meetings with management helped to curtail a lot of issues. He suggested to Rokes that the county and labor representatives should meet at least once per quarter, if not more often, going forward in order to resolve problems before they become large enough to warrant discussion in a public forum like the board of supervisors meeting. Rokes agreed.</p>
</p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.mtshastanews.com/subscribe?g2i_source=mtshastanews.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
							<h2>Sign up for daily e-mails</h2>
							<a href="http://myprofile.mtshastanews.com">
								<button type="button" class="btn btn-subscribe">
									Sign up
								</button>
							</a>							
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.mtshastanews.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_MTS" target="_top">My Profile</a></li><li><a href="http://mountshasta.ca.newsmemory.com" target="_blank">E-Edition</a></li><li><a href="https://www.mtshastanews.com/submit" target="_top">Submit a News Item</a></li><li><a href="https://www.mtshastanews.com/contact" target="_blank">Contact Us</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/camts-classified/index.html" target="_top">Place a Classified Ad</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://mediakit.gatehousemedia.com/MountShasta_CA" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Casis" target="_blank">Classifieds</a></li><li><a href="https://www.mtshastanews.com/homes" target="_top">Homes</a></li><li><a href="https://www.mtshastanews.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Schools<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.sisuhsd.net" target="_blank">Siskiyou Union High School District</a></li><li><a href="http://www.siskiyous.edu" target="_blank">College of the Siskiyous</a></li><li><a href="http://www.mtshasta.k12/ca/us/" target="_blank">Mount Shasta and Weed Elementary School Districts</a></li><li><a href="http://www.dunsmuirhigh.k12.ca.us" target="_blank">Dunsmuir High School</a></li><li><a href="http://www.sisnet.ssku.k12.ca.us/~desftp/" target="_blank">Dunsmuir Elementary</a></li><li><a href="http://www.castlerockschool.net" target="_blank">Castle Rock Elementary</a></li><li><a href="http://be-buesd-ca.schoolloop.com" target="_blank">Butteville Elementary</a></li><li><a href="http://sisnet.ssku.k12.ca.us/~cloudftp/mccloud_home_page.htm" target="_blank">McCloud Elementary</a></li></ul></div><div class="footer-col"><h4>Communities<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.ci.dunsmuir.ca.us/" target="_blank">City of Dunsmuir</a></li><li><a href="http://www.lakeshastina.com/" target="_blank">Lake Shastina</a></li><li><a href="http://ci.mt-shasta.ca.us/" target="_blank">City of Mount Shasta</a></li><li><a href="http://www.ci.weed.ca.us/" target="_blank">City of Weed</a></li><li><a href="http://www.ci.yreka.ca.us/" target="_blank">City of Yreka</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=CA&date=20190926&category=NEWS&lopenr=190929883&Ref=AR -->
			<div id="footer-main-copyright">
											<p id="footer-copyrightInfo">&copy; Copyright 2006-2019 <a href="http://www.gatehousemedia.com/about-us/" target="_blank">GateHouse Media, LLC.</a> All rights reserved&nbsp;&nbsp;&bull;&nbsp;&nbsp;GateHouse News</p>
							<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
							<br />Mount Shasta Herald - Mount Shasta, CA  ~ 924 N. Mount Shasta Blvd. (P.O. Box 127), Mount Shasta, CA 96067 ~ <a href="http://www.gatehousemedia.com/privacy-policy/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gatehousemedia.com/terms_of_use/" target="_blank">Terms Of Service</a></p>
							<script>document.getElementById('footer-main-copyright').getElementsByTagName('p')[1].innerHTML += '<a href="/ownership"><img id="footer-main-gh-logo" src="//cdn.gatehousemedia.com/gh-sites/global/images/logo/ghlogo_horizontal.png" alt="Gatehouse Media Logo"></a>'</script>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.mtshastanews.com/subscribe?g2i_source=mtshastanews.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.mtshastanews.com" target="_top">Home</a></li><li><a href="https://www.mtshastanews.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"12487"><a href="https://www.mtshastanews.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"12488"><a href="https://www.mtshastanews.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"12489"><a href="https://www.mtshastanews.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"12490"><a href="https://www.mtshastanews.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"12492"><a href="https://www.mtshastanews.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"12491"><a href="https://www.mtshastanews.com/news/shareable" target="_top">Shareable</a></li><li id="navLink-TEST-"43463"><a href="https://www.mtshastanews.com/mtshasta-legal-notices" target="_top">Public Legal Notices</a></li></ul></li><li><a href="https://www.mtshastanews.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"12495"><a href="https://www.mtshastanews.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.mtshastanews.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"12498"><a href="https://www.mtshastanews.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"12499"><a href="https://www.mtshastanews.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"12500"><a href="https://www.mtshastanews.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"12501"><a href="https://www.mtshastanews.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"12477"><a href="https://www.mtshastanews.com/entertainment/tv-guide" target="_top">TV Guide</a></li><li id="navLink-TEST-"38478"><a href="https://www.mtshastanews.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.mtshastanews.com/lifestyle"><span class="nav-category">Life</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"12505"><a href="https://www.mtshastanews.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"12506"><a href="https://www.mtshastanews.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"12507"><a href="https://www.mtshastanews.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"12508"><a href="https://www.mtshastanews.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"12509"><a href="https://www.mtshastanews.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"12510"><a href="https://www.mtshastanews.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"12511"><a href="https://www.mtshastanews.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"12512"><a href="https://www.mtshastanews.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.mtshastanews.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"12515"><a href="https://www.mtshastanews.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"12516"><a href="https://www.mtshastanews.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"12517"><a href="https://www.mtshastanews.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.mtshastanews.com/business-news" target="_top">Business</a></li><li><a href="https://www.mtshastanews.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.mtshastanews.com/section/blogs" target="_top">Blogs</a></li><li><a href="https://www.mtshastanews.com/photos" target="_top">Photos</a></li><li><a href="https://www.mtshastanews.com/videos" target="_top">Videos</a></li><li><a href="https://www.mtshastanews.com/calendar" target="_top">Calendar</a></li><li><a href="http://games.mtshastanews.com" target="_top">Games</a></li><li><a href="https://www.mtshastanews.com/contests" target="_top">Contests</a></li><li><a href="https://www.mtshastanews.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.mtshastanews.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.mtshastanews.com/mtshasta-legal-notices" target="_top">Public Legal Notices</a></li><li><a href="https://www.mtshastanews.com/section/promoted//?prx_adpz=2240" target="_top">From Our Advertisers</a></li><li><a href="https://www.mtshastanews.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.mtshastanews.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_MTS" target="_top">My Profile</a></li><li><a href="http://mountshasta.ca.newsmemory.com" target="_blank">E-Edition</a></li><li><a href="https://www.mtshastanews.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://mediakit.gatehousemedia.com/MountShasta_CA" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Casis" target="_blank">Classifieds</a></li><li><a href="https://www.mtshastanews.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.mtshastanews.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.mtshastanews.com/homes" target="_top">Homes</a></li><li><a href="https://www.mtshastanews.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://mtshastanews.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:news@mtshastanews.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/terms_of_use/">Terms of Use</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/privacy-policy/">Privacy Policy</a>
		</li>
		<li>
			<a href="http://www.gatehousemedia.com/our-markets/">GateHouse Media Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.mtshastanews.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/Mount-Shasta-Area-Newspapers/133629674684""
								target="_blank"
								title="Mount Shasta Herald - Mount Shasta, CA Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="Mount Shasta Herald - Mount Shasta, CA RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.mtshastanews.com/contact"
								title="Contact Mount Shasta Herald - Mount Shasta, CA">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
        <a href="http://mtshastanews.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.mtshastanews.com/apps/pbcs.dll/article?avis=CA&date=20190926&category=NEWS&lopenr=190929883&Ref=AR"}'>
            Learn More
        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.376/app.min.js" crossorigin="anonymous"></script>
		<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
		<script>
		function __gh__init() {
			var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
		<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2019-09-26&nbsp;19:49:14-->
	<script async type="text/javascript" src="/_Incapsula_Resource?SWJIYLWA=719d34d31c8e3a6e6fffd425f7e032f3&ns=2&cb=601126454"></script>
</body>
</html>